Unable to Access Email via Envelope in Toolbar
Symptom:
When I click the envelope at the upper-right of eCampus, and choose Inbox, nothing happens.
Cause:
This may caused by a slow Internet connection.
Resolution:
To resolve this issue, perform the following:

Method 1
  1. Login to portal.phoenix.edu
  2. Locate Quick Links from top left of Home page
  3. Click Microsoft Office 365
  4. Click Outlook email icon 
Outlook Icon
Method 2
  1. Navigate to portal.office365.com
  2. Enter university email [username]@email.phoenix.edu
  3. Click in Password field
    Note: This will redirect to the eCampus login page
  4. Enter eCampus credentials
  5. Click Login
Method 3
  1. Go to portal.phoenix.edu
  2. Type in your username and password
  3. Click Go To Inbox
 
 
Additional Information:
There is no additional information.
We welcome and appreciate your feedback!
Share
Subscribe
Enter your email address to receive a notification when the article is updated
Email Address
Subscribe
Unsubscribe
Share
To
Subject
Message
Send

Was this article helpful
Thank you for your feedback
How can we improve?